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Using a web proxy server for Bravura Security Fabric to reach out to its targets

Problem

When an environment uses a proxy server to access web content, Bravura Security Fabric connectors, scripts, and other programs may not be able to reach external targets. The result is a connection timeout.

Cause

Bravura Security Fabric connectors use the Windows proxy settings (not always the ones from Control Panel> Internet Options), which must be set manually.

Solution

  1. In an administrative command prompt type:

    netsh winhttp set proxy
    
    <my-proxy.company.com>:443

    Replace the proxy server name with the one in the actual environment.

  2. Restart all services (at a minimum, iddb and w3svc)

This should allow setting the proper proxy server and port in the winhttp configuration that Bravura Security Fabric uses. External targets should connect.